<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">

<head profile="http://gmpg.org/xfn/11">

<link rel="shortcut icon" href="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/favicon.ico" />

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<meta name="viewport" content="width=device-width" />

<title>   Film review: ‘T2 Trainspotting’  : Frost Illustrated</title>

<link rel="stylesheet" href="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/style.css" type="text/css" media="screen" />

<link rel="pingback" href="http://www.frostillustrated.com/xmlrpc.php" />

<!--[if lt IE 9]>
<script src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<![endif]-->

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/250237259/728x90_Top', [728, 90], 'div-gpt-ad-1424983054809-0').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_bottom-r_220x90_theme', [220, 90], 'div-gpt-ad-1429757226745-0').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_rsb_300x250_b', [300, 250], 'div-gpt-ad-1424983054809-5').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_rsb_300x250_c', [300, 250], 'div-gpt-ad-1424983054809-6').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_rsb_300x250_top', [300, 250], 'div-gpt-ad-1424983054809-7').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_top-r_220x90_theme', [220, 90], 'div-gpt-ad-1429758940391-0').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_lsb125x125_c', [[120, 600], [120, 60], [125, 125], [120, 90], [120, 240]], 'div-gpt-ad-1429758259836-0').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_lsb_tall', [[120, 600], [120, 240]], 'div-gpt-ad-1429758259836-1').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_rsb_300x600', [300, 600], 'div-gpt-ad-1429758259836-2').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_header_468x90', [468, 60], 'div-gpt-ad-1429758259836-3').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_in-page', [[468, 60], [120, 600], [125, 125]], 'div-gpt-ad-1429758259836-4').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_bottom_728x90', [728, 90], 'div-gpt-ad-1429758259836-5').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_lsb_125x125_b', [125, 125], 'div-gpt-ad-1429758259836-6').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_lsb_125x125_top', [125, 125], 'div-gpt-ad-1429758259836-7').addService(googletag.pubads());
googletag.defineSlot('/250237259/FI_rsb_300x250_top_OBITS', [300, 250], 'div-gpt-ad-1429758259836-8').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>


<link rel="alternate" type="application/rss+xml" title="Frost Illustrated &raquo; Feed" href="http://www.frostillustrated.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Frost Illustrated &raquo; Comments Feed" href="http://www.frostillustrated.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.frostillustrated.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.2.14"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jetpack-top-posts-widget-css'  href='http://www.frostillustrated.com/wp-content/plugins/jetpack/modules/widgets/top-posts/style.css?ver=20141013' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.frostillustrated.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.frostillustrated.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.5.3' type='text/css' media='all' />
<!-- This site uses the Google Analytics by Yoast plugin v5.4.6 - Universal enabled - https://yoast.com/wordpress/plugins/google-analytics/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-40572735-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('set', 'anonymizeIp', true);
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by Yoast -->
<script type='text/javascript' src='http://www.frostillustrated.com/wp-includes/js/jquery/jquery.js?ver=1.11.2'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/js/flexslider.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/js/external.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/js/suckerfish.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/js/suckerfish-cat.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/admin/jquery-ui-personalized-1.5.2.packed.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/themes/wp-prosper204/admin/sprinkle-tabs.js?ver=4.2.14'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.frostillustrated.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.frostillustrated.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Rightly dividing the word of truth' href='http://www.frostillustrated.com/2017/rightly-dividing-the-word-of-truth/' />
<meta name="generator" content="WordPress 4.2.14" />
<link rel='canonical' href='http://www.frostillustrated.com/2017/film-review-t2-trainspotting/' />
<link rel='shortlink' href='http://wp.me/p3eeuh-l5M' />
<meta name="news_keywords" content="aniela nedyalkova, danny boyle, dwight brown, ewan mcgregor, ewen bremner, frost illustrated, jonny lee miller, nnpa, review, t2 trainspotting"><style type='text/css'>img#wpstats{display:none}</style>
<!-- Alternate Stylesheet -->
<link href="http://www.frostillustrated.com/wp-content/themes/wp-prosper204/styles/default.css" rel="stylesheet" type="text/css" />

<!-- Custom Styles from Theme Setting Page -->
<style type="text/css">
body {color:#141414;}
#sitetitle,#logo {float:left;width:49%;}
#sitetitle .title {font-size:36px;font-weight:bold;}
#sitetitle .title,#sitetitle .description {float:none;text-indent:-999em;position:absolute;display:none;left:-999em;}
#catnav,#catnav ul ul a {background-color:#3399ff;}
#catnav {border:0;} #catnav ul ul,#catnav ul ul a {border-color:#fff;}
#catnav ul a,#catnav ul ul a {color:#000000;}
#catnav ul a:hover,#catnav ul ul a:hover {color:#000000;}
#catnav ul a:hover,#catnav ul ul a:hover {background-color:#336699;}
.maincontent {font-size:10pt;}
#commentform input#submit,.archive-tabs a,.archive-tabs a:link,.archive-tabs a:visited,a.more-link,a.more-link:link,a.more-link:visited,#searchform #submitbutton,p.email-form .subbutton,a.comment-reply-link,a.comment-reply-link:link,a.comment-reply-link:visited {border-color:#0099ff;background-color:#0099ff;}
</style>

<!-- Styles from custom.css -->
<link href="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/custom.css" rel="stylesheet" type="text/css" />


<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Film review: ‘T2 Trainspotting’" />
<meta property="og:url" content="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/" />
<meta property="og:description" content="By Dwight Brown (NNPA Newswire Film Critic) “Trainspotting” was a breakthrough film back in 1996. An edgy, eccentric blend of debauchery and rebellion set to one of the best British rock soundtrack..." />
<meta property="article:published_time" content="2017-04-22T15:42:53+00:00" />
<meta property="article:modified_time" content="2017-04-21T15:46:15+00:00" />
<meta property="article:author" content="http://www.frostillustrated.com/author/mpatterson/" />
<meta property="og:site_name" content="Frost Illustrated" />
<meta property="og:image" content="http://www.frostillustrated.com/wp-content/uploads/2017/04/t2_trainspotting_sony_web120.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@frostwebfeed" />
<meta name="twitter:image:src" content="http://www.frostillustrated.com/wp-content/uploads/2017/04/t2_trainspotting_sony_web120.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@frostwebfeed" />
			<link rel="stylesheet" id="custom-css-css" type="text/css" href="http://www.frostillustrated.com/?custom-css=1&#038;csblog=1&#038;cscache=6&#038;csrev=51" />
			
</head>

<body class="single single-post postid-81082 single-format-standard sn-c-sw">

<div id="body-bg"></div>

<div id="topnav">
	<div class="limit clearfix">
					<ul class="clearfix">
				<li id="menu-item-70255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70255"><a href="http://www.frostillustrated.com/app/">App</a></li>
<li id="menu-item-3301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3301"><a href="http://www.frostillustrated.com/classifieds/">Classifieds</a></li>
<li id="menu-item-4250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4250"><a href="http://www.frostillustrated.com/events/">Events</a></li>
<li id="menu-item-78897" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78897"><a href="http://www.frostillustrated.com/frost-tv-2/">Frost TV</a></li>
				<li class="searchform"><form id="searchform" method="get" action="http://www.frostillustrated.com/" ><input type="text" value="Enter Search Terms" onfocus="if (this.value == 'Enter Search Terms') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Enter Search Terms';}" size="18" maxlength="50" name="s" id="searchfield" /><input type="submit" value="search" id="submitbutton" /></form>
</li>
			</ul>
			</div>
</div>

<div id="header">
	<div id="head-content" class="clearfix">
					<div id="logo">
				<a href="http://www.frostillustrated.com" title="Frost Illustrated"><img src="http://www.frostillustrated.com/wp-content/uploads/2013/03/FROST-header-300x43.png" alt="Frost Illustrated" /></a>
			</div>
				<div class="head-banner468">
	<!-- /250237259/FI_header_468x90 -->
<div id='div-gpt-ad-1429758259836-3' style='height:60px; width:468px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1429758259836-3'); });
</script>
</div></div>
	</div>
</div>

<div id="outer-wrap">

		<div id="catnav">
		<div class="limit clearfix">
							<ul class="clearfix">
					<li id="menu-item-70880" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-70880"><a href="http://www.frostillustrated.com/home/">Home</a></li>
<li id="menu-item-323" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-323"><a href="http://www.frostillustrated.com/home/">NEWS</a>
<ul class="sub-menu">
	<li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67"><a href="http://www.frostillustrated.com/category/local-2/">Local</a></li>
	<li id="menu-item-69" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69"><a href="http://www.frostillustrated.com/category/national-2/">National</a></li>
	<li id="menu-item-71287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71287"><a href="http://www.frostillustrated.com/category/local-2/crime-safety/">Crime &#038; Safety</a></li>
	<li id="menu-item-320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-320"><a href="http://www.frostillustrated.com/category/spiritual-matters/obituaries/">Obituaries</a></li>
	<li id="menu-item-75634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75634"><a href="http://www.frostillustrated.com/category/sports-2/">Sports</a></li>
	<li id="menu-item-71288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71288"><a href="http://www.frostillustrated.com/category/events/">Events</a></li>
</ul>
</li>
<li id="menu-item-70257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70257"><a href="http://www.frostillustrated.com/category/opinion-2/">VIEWS</a>
<ul class="sub-menu">
	<li id="menu-item-70258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70258"><a href="http://www.frostillustrated.com/author/ehackley/">Eric Hackley</a></li>
	<li id="menu-item-70259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70259"><a href="http://www.frostillustrated.com/author/jsummerville/">Jeanie Summerville</a></li>
	<li id="menu-item-70260" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70260"><a href="http://www.frostillustrated.com/?s=%22Nnpa+columnist%22">NNPA Columnists</a></li>
	<li id="menu-item-70261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70261"><a href="http://www.frostillustrated.com/author/gdeas/">Dr. Deas</a></li>
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="http://www.frostillustrated.com/category/spiritual-matters/">Spiritual Matters</a></li>
</ul>
</li>
<li id="menu-item-321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-321"><a href="http://www.frostillustrated.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-322"><a href="http://www.frostillustrated.com/about/where-to-buy-frost/">Where to buy Frost</a></li>
	<li id="menu-item-328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-328"><a href="http://www.frostillustrated.com/subscribe/">Subscribe</a></li>
	<li id="menu-item-368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368"><a href="http://www.frostillustrated.com/about/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-364"><a href="http://www.frostillustrated.com/about/advertise/">Advertise</a></li>
<li id="menu-item-75019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75019"><a href="http://www.frostillustrated.com/category/videos/">VIDEO</a></li>
<li id="menu-item-75020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-75020"><a href="http://www.frostillustrated.com/category/photos/">PHOTOS</a></li>
<li id="menu-item-78891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78891"><a href="http://www.frostillustrated.com/frost-tv-2/">Frost TV</a></li>
				</ul>
					</div>
	</div>
	
	<div id="wrap">

		
<div class="banner728-container clearfix">
	<div class="banner728">
		<!-- 728x90 Top -->
<div id='div-gpt-ad-1424983054809-0' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1424983054809-0'); });
</script>
</div>	</div>
	</div>

	
	
	<div id="page" class="clearfix">

		<div id="contentleft">

			
			
			
			<div id="content" class="maincontent">

				
				

				<div class="singlepost">

					<div class="post" id="post-main-81082">

						<div class="entry">

							<h1 class="post-title single"><a href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/" rel="bookmark" title="Permanent Link to Film review: ‘T2 Trainspotting’">Film review: ‘T2 Trainspotting’</a></h1>

							<div class="meta single">

	<span class="meta-author">
		<a href="http://www.frostillustrated.com/author/mpatterson/" title="Posts by Frost Editor" rel="author">Frost Editor</a> | 
	</span>

	<span class="meta-date">
		April 22, 2017	</span> 

	
</div>
							
							<div id="attachment_81275" style="width: 310px" class="wp-caption alignright"><a href="http://www.frostillustrated.com/wp-content/uploads/2017/04/t2_trainspotting_sony_web120.jpg"><img class="wp-image-81275 size-medium" src="http://www.frostillustrated.com/wp-content/uploads/2017/04/t2_trainspotting_sony_web120-300x171.jpg" alt="(From left-right) Jonny Lee Miller, Ewan McGregor and Anjela Nedyalkova in “T2 Trainspotting.” (Sony)" width="300" height="171" /></a><p class="wp-caption-text">(From left-right) Jonny Lee Miller, Ewan McGregor and Anjela Nedyalkova in “T2 Trainspotting.” (Sony)</p></div>
<p><em><strong>By Dwight Brown (NNPA Newswire Film Critic)</strong></em></p>
<p>“Trainspotting” was a breakthrough film back in 1996. An edgy, eccentric blend of debauchery and rebellion set to one of the best British rock soundtracks ever made. Twenty years later, the original director Danny Boyle (“Slumdog Millionaire,” “28 Days Later”) and screenwriter John Hodge assemble the same set of Scottish miscreants and make them deal with the aftermath of a betrayal that affected all their lives.</p>
<p>In the ‘90s film, Mark (Ewan McGregor) and Simone, aka Sick Boy (Jonny Lee Miller), were best friends since childhood. In their mid-twenties, they hung out with the tall skinny dullard Daniel “Spud” Murphy (Ewen Bremner) and the short, violent and temperamental Francis “Franco” Begbie (Robert Carlyle). The four of them, and other comrades, had one thing in common: heroin addiction. It united them. Broke them apart. Caused death and destruction. Their depraved indifference to life and traditional mores ended with a dope deal gone bad. Mark, who flirted with sobriety, ran off with £12,000 pounds. He left Spud £4,000, which went right into his arm. Simone got nothing. Franco got a jail sentence and a grudge against Mark that was eating him alive.</p>
<p>In 2017, nearing middle age, Mark’s yuppyish job at a Dutch software company ends. He returns to the scene of the crime, Edinburg. These days, Simone, a cokehead, is in love with a prostitute named Veronika (Anjela Nedyalkova). The couple makes money by blackmailing clients, “Johns,” who are secretly videotaped as they bed Veronika, who dresses up as a dominatrix.</p>
<p>Spud is a bit of a depressed loner. In fact, Mark is banging at the door of his flat just as his dejected friend is attempting suicide. Mark saves his life and Spud’s sour response is: “You ruined my life, and my death.” Meanwhile, the fiercely vindictive Franco is plotting an escape from jail. The reunion of these four is fraught with more anger, deceit, maleficence, apologies and ill will than a feud between Mick Jagger and Keith Richards.</p>
<p>It’s a hard task recapturing the dark humor and light spirits that made the original movie so shocking yet endearing. This script puts Mark and Simon on a mission to build a spa (brothel) that Veronika can operate. Mark, whose libido knows no bounds, flirts with Veronika, knowing that Simon loves her. But that’s Mark’s M.O: he can’t be trusted with a friend’s girlfriend. The character that gets the best facelift is Spud, who dares to dream big and finds an ounce of courage, when he had none in the first film. Franco, who makes a junkyard dog look like a prince, is so mean and violent he alienates himself from his family and goes after Mark with a sheer vengeance.</p>
<p>Boyle has a fun way with the footage. He will stop it cold; shoot scenes at odd angles (cinematographer Anthony Dod Mantle, “Slumdog Millionaire”); Cut in flashbacks (editor Jon Harris, “Kingsman: The Secret Service”); and add colorful and textured dreamy images over scenes (production design Patrick Rolfe and Mark Tildesley; art direction Patrick Rolfe). It is a pleasure to watch him weave his artistic magic. And though the soundtrack doesn’t boast a song as catchy as the first movie’s hit tune “Lust for Life,” some of the kinetic music has a throbbing beat.</p>
<p>Boyle’s innovation helps greatly as you realize that this script is not as fresh as the 1996 one, which was based on a novel by Irvine Welsh. That screenplay treaded new territory that audiences couldn’t fathom: Piss poor Scottish adolescents, living in and around wealth and middle-class amenities, unable to hold down a nine-to-five and relegated to a parallel world. Their degeneracy and irresponsibility had no limits, and they were so oblivious to reality that a baby died while in their custody. That stream of decadence was a jolt to the senses. Nothing in this film is quite as shocking. But then again, what could be?</p>
<p>McGregor, Miller, Bremmer and Carlyle slip into their old characters, friendships, jealousies and rivalries comfortably—like they were trying on a pair of old faded, torn jeans that still fit or dusting off old drug paraphernalia. At one point Veronika points out to Mark “You’re a tourist in your own youth.” That’s the way it feels watching these graying, saggy-eyed fortysomethings trying to get their mojo back. They can’t relive their lives, but they can die trying.</p>
<p>In the end, there is something woefully nostalgic about watching McGregor, Miller, Bremner and Carlyle running down the cobblestone streets of Edinburg with an urgency and abandonment that is similar to the chaos they wreaked in “Trainspotting.”</p>
<p>The guys are a few paces slower, and almost as reckless. Just like T2.</p>
<p><em>Dwight Brown is a film critic and travel writer. As a film critic, he regularly attends international film festivals including Cannes, Sundance, Toronto and the American Black Film Festival. Read more movie reviews by Dwight Brown here and at DwightBrownInk.com.</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-81082" class="share-facebook sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-81082" class="share-twitter sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-81082" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-81082" class="share-linkedin sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-81082" class="share-pinterest sd-button share-icon no-text" href="http://www.frostillustrated.com/2017/film-review-t2-trainspotting/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
							<div style="clear:both;"></div>

							
							<p class="tags"><strong>Tags: </strong> <a href="http://www.frostillustrated.com/tag/aniela-nedyalkova/" rel="tag">aniela nedyalkova</a>, <a href="http://www.frostillustrated.com/tag/danny-boyle/" rel="tag">danny boyle</a>, <a href="http://www.frostillustrated.com/tag/dwight-brown/" rel="tag">dwight brown</a>, <a href="http://www.frostillustrated.com/tag/ewan-mcgregor/" rel="tag">ewan mcgregor</a>, <a href="http://www.frostillustrated.com/tag/ewen-bremner/" rel="tag">ewen bremner</a>, <a href="http://www.frostillustrated.com/tag/frost-illustrated/" rel="tag">frost illustrated</a>, <a href="http://www.frostillustrated.com/tag/jonny-lee-miller/" rel="tag">jonny lee miller</a>, <a href="http://www.frostillustrated.com/tag/nnpa/" rel="tag">nnpa</a>, <a href="http://www.frostillustrated.com/tag/review/" rel="tag">review</a>, <a href="http://www.frostillustrated.com/tag/t2-trainspotting/" rel="tag">t2 trainspotting</a></p>							<p class="cats"><strong>Category</strong>: <a href="http://www.frostillustrated.com/category/entertainment-2/" rel="category tag">Entertainment</a></p>

						</div>

						<div class="auth-bio clearfix">
	<div class="bio">
		<img alt='' src='http://2.gravatar.com/avatar/b8d06ea2842ccfd5e7db161db0bc77e5?s=24&#038;d=mm&#038;r=pg' srcset='http://2.gravatar.com/avatar/b8d06ea2842ccfd5e7db161db0bc77e5?s=48&amp;d=mm&amp;r=pg 2x' class='avatar avatar-24 photo' height='24' width='24' />		<h3>About the Author <span class="profile">(<a rel="author" href="http://www.frostillustrated.com/?author=9">Author Profile</a>)</span></h3>
		Frost Illustrated is Fort Wayne's oldest weekly newspaper. Your Independent Voice in the Community, featuring news &amp; views of African Americans since 1968.	</div>
</div>

						
						
<!-- You can start editing here. -->

<div class="allcomments">


			<!-- If comments are closed. -->
		<p class="nocomments">Comments are closed.</p>

	

</div>


					</div>

					<div class="navigation clearfix">
	<div class="alignleft single">
		&laquo; <a href="http://www.frostillustrated.com/2017/rightly-dividing-the-word-of-truth/" rel="prev">Rightly dividing the word of truth</a>	</div>
	<div class="alignright single">
			</div>
</div>
				</div>


			</div>

			
<div id="sidebar-narrow" class="clearfix">

	<div id="top-posts-3" class="widget widget_top-posts"><div class="widget-wrap"><h3 class="widgettitle"><span>Top Posts &amp; Pages</span></h3><ul>				<li>
										<a href="http://www.frostillustrated.com/2014/james-jim-redmond-declares-war-on-jackleg-preachers/" class="bump-view" data-bump-view="tp">
						James &#039;Jim&#039; Redmond ‘declares war’ on jackleg preachers					</a>
									</li>
							<li>
										<a href="http://www.frostillustrated.com/2013/grease-your-knees-walk-with-ease/" class="bump-view" data-bump-view="tp">
						Grease your knees, walk with ease  					</a>
									</li>
							<li>
										<a href="http://www.frostillustrated.com/2015/still-talking-n-word/" class="bump-view" data-bump-view="tp">
						We’re still talking about the N-word…					</a>
									</li>
							<li>
										<a href="http://www.frostillustrated.com/2017/man-killed-at-fort-wayne-strip-club/" class="bump-view" data-bump-view="tp">
						Man killed at Fort Wayne strip club					</a>
									</li>
							<li>
										<a href="http://www.frostillustrated.com/2017/spotlight-on-raymond-h-merkson-owner-of-detroit-detail-locksmith/" class="bump-view" data-bump-view="tp">
						Spotlight on Raymond H. Merkson, owner of Detroit Detail Locksmith					</a>
									</li>
			</ul></div></div><div id="bannerad-widget-16" class="widget bannerad"><div class="widget-wrap"><!-- /250237259/FI_lsb_125x125_b -->
<div id='div-gpt-ad-1429758259836-6'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1429758259836-6'); });
</script>
</div></div></div><div id="bannerad-widget-13" class="widget bannerad"><div class="widget-wrap"><!-- /250237259/FI_lsb_125x125_top -->
<div id='div-gpt-ad-1429758259836-7'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1429758259836-7'); });
</script>
</div></div></div><div id="bannerad-widget-3" class="widget bannerad"><div class="widget-wrap"><!-- /250237259/FI_lsb_tall -->
<div id='div-gpt-ad-1429758259836-1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1429758259836-1'); });
</script>
</div></div></div>
</div>


		</div>


		<div id="contentright">

			<div id="sidebar" class="clearfix">
				<div id="widget_sp_image-7" class="widget widget_sp_image"><div class="widget-wrap"><h3 class="widgettitle"><span>LM-online-300</span></h3><a href="http://www.fwcivic.org/Page201617_Show_TheLittleMermaid.html" id="" target="_blank" class="widget_sp_image-image-link" title="LM-online-300" rel=""><img width="300" height="250" alt="LM-online-300" class="attachment-full" style="max-width: 100%;" src="http://www.frostillustrated.com/wp-content/uploads/2017/04/LM-online-300.jpg" /></a></div></div><div id="widget_sp_image-4" class="widget widget_sp_image"><div class="widget-wrap"><a href="https://lakecitybank.mortgagewebcenter.com/" id="" target="_blank" class="widget_sp_image-image-link" title="" rel=""><img width="300" height="250" alt="" class="attachment-full" style="max-width: 100%;" src="http://www.frostillustrated.com/wp-content/uploads/2016/09/LCB_Mortgage_300x250_digital.jpg" /></a></div></div><div id="widget_sp_image-6" class="widget widget_sp_image"><div class="widget-wrap"><a href="https://0230168806.mortgage-application.net/Default.aspx" id="" target="_blank" class="widget_sp_image-image-link" title="" rel=""><img width="625" height="521" alt="" class="attachment-full" style="max-width: 100%;" src="http://www.frostillustrated.com/wp-content/uploads/2016/04/Frost_Illus_Web_Ad_Mortgage_300px_x250px_Color.jpg" /></a></div></div><div id="text-6" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle"><span>Frost Facebook Fans</span></h3>			<div class="textwidget"><iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2FFrostIllustrated&amp;width&amp;layout=standard&amp;action=like&amp;show_faces=false&amp;share=false&amp;height=35" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:35px;" allowTransparency="true"></iframe></div>
		</div></div><div id="socialicons-widget-2" class="widget socialicons"><div class="widget-wrap"><div class="textwidget"><p>Stay cool & connected with Frost Illustrated!</p>
		<div class="sub-icons clearfix">

	<a title="Subscribe via RSS Feed" href="http://www.frostillustrated.com/feed/"><img class="rss-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/feed.png" alt="Subscribe via RSS Feed" align="top" /></a>

	<a rel="external" title="Follow us on Twitter!" href="http://www.twitter.com/frostillustrate"><img class="twitter-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/twitter.png" alt="Follow us on Twitter!" align="top" /></a>

	<a title="Connect on Facebook" rel="external" href="http://www.facebook.com/frostillustrated"><img class="facebook-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/facebook.png" alt="Connect on Facebook" align="top" /></a>

	<a title="Connect on Google Plus" rel="external" href="https://plus.google.com/+frostillustrated?rel=author"><img class="gplus-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/google-plus.png" alt="Connect on Google Plus" align="top" /></a>






</div>
		</div>
		</div></div><div id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-081711.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//frostillustrated.us7.list-manage.com/subscribe/post?u=c73761f4a4b795781d033149d&amp;id=226de42008" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2>Stay connected with Frost email updates!</h2>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address </label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group">
	<label for="mce-FNAME">First Name </label>
	<input type="text" value="" name="FNAME" class="required" id="mce-FNAME">
</div>
<div class="mc-field-group">
	<label for="mce-MMERGE4">Zip Code </label>
	<input type="text" value="" name="MMERGE4" class="required" id="mce-MMERGE4">
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;"><input type="text" name="b_c73761f4a4b795781d033149d_226de42008" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[4]='MMERGE4';ftypes[4]='zip';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div></div><div id="catposts-widget-3" class="widget catposts"><div class="widget-wrap"><h3 class="widgettitle"><span><a href="http://www.frostillustrated.com/category/videos/">Videos</a></span></h3><div class='cat-posts-widget textwidget'>
				<div class="post">
					<div class="entry clearfix">
						<a href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/" rel="bookmark" title="Permanent Link to Video interview with Rose Broadnax on Justice or Else march">		<img class="thumbnail" src="http://www.frostillustrated.com/wp-content/uploads/2015/11/BrotherRose-5-e1447690791299-150x150.jpg" alt="Video interview with Rose Broadnax on Justice or Else march" title="Video interview with Rose Broadnax on Justice or Else march" />
	</a>
						<p class="post-title"><a href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/" rel="bookmark" title="Permanent Link to Video interview with Rose Broadnax on Justice or Else march">Video interview with Rose Broadnax on Justice or Else march</a></p>
						<p>By Eric D. Hackley Click here to read the transcript Brother Rose the Home Repair Contractor discusses the liberating potential of the &#8220;Justice or Else&#8221; Movement. He discusses the ways we were brainwashed and the eradication of &#8220;slave mentality.&#8221; He also discusses the involvement of the Whites, Indians, Mexicans and others. Brother Rose and I [&hellip;]</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-75967" class="share-facebook sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-75967" class="share-twitter sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-75967" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-75967" class="share-linkedin sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-75967" class="share-pinterest sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/video-interview-with-rose-broadnax-on-justice-or-else-march/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					</div>
					<div class="meta single">

	<span class="meta-author">
		<a href="http://www.frostillustrated.com/author/ehackley/" title="Posts by Eric Donald Hackley" rel="author">Eric Donald Hackley</a> | 
	</span>

	<span class="meta-date">
		November 19, 2015	</span> 

	
</div>					<div style="clear:both;"></div>
				</div>
						<div class="post">
					<div class="entry clearfix">
						<a href="http://www.frostillustrated.com/2015/interview-with-nicole-king/" rel="bookmark" title="Permanent Link to Interview with Nicole King">		<img class="thumbnail" src="http://www.frostillustrated.com/wp-content/uploads/2015/11/Nicole-3-150x150.jpg" alt="Interview with Nicole King" title="Interview with Nicole King" />
	</a>
						<p class="post-title"><a href="http://www.frostillustrated.com/2015/interview-with-nicole-king/" rel="bookmark" title="Permanent Link to Interview with Nicole King">Interview with Nicole King</a></p>
						<p>Video by Eric Hackley Fort Wayne Activist/Educator and Lady Leader Nicole King shares the very personal side of the &#8220;Justice or Else&#8221; Washington, DC March and why she not only had to attend, but why she took her children. Related</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-75868" class="share-facebook sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-75868" class="share-twitter sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-75868" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-75868" class="share-linkedin sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-75868" class="share-pinterest sd-button share-icon no-text" href="http://www.frostillustrated.com/2015/interview-with-nicole-king/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					</div>
					<div class="meta single">

	<span class="meta-author">
		<a href="http://www.frostillustrated.com/author/ehackley/" title="Posts by Eric Donald Hackley" rel="author">Eric Donald Hackley</a> | 
	</span>

	<span class="meta-date">
		November 10, 2015	</span> 

	
</div>					<div style="clear:both;"></div>
				</div>
		</div>
</div></div><div id="rss-4" class="widget widget_rss"><div class="widget-wrap"><h3 class="widgettitle"><span><a class='rsswidget' href='http://www.dayinblackhistory.com/todayrss.aspx'><img style='border:0' width='14' height='14' src='http://www.frostillustrated.com/wp-includes/images/rss.png' alt='RSS' /></a> <a class='rsswidget' href='http://www.dayinblackhistory.com/'>Today in Black History</a></span></h3><ul><li><a class='rsswidget' href='http://www.dayinblackhistory.com/showarticle2858.aspx'>Charles Mingus</a><div class="rssSummary">1922 ~ (bassist, composer, pianist and bandleader) born</div></li><li><a class='rsswidget' href='http://www.dayinblackhistory.com/showarticle2459.aspx'>Major slave revolt in South Carolina</a><div class="rssSummary">1739 ~ A major slave revolt occurs in South Carolina, lead by a slave named Cato, resulting in the deaths of twenty to thirty Whites who attempted to stop their trek to Florida and the eventual deaths of dozens of escaped slaves</div></li><li><a class='rsswidget' href='http://www.dayinblackhistory.com/showarticle3119.aspx'>Protest at Yale</a><div class="rssSummary">1970 ~ Students protest at Yale University in support of the Black panthers</div></li></ul></div></div>			</div>

			<div id="sidebar-bottom" class="clearfix">

				<div id="sidebar-bottom-left">
														</div>

				<div id="sidebar-bottom-right">
														</div>

			</div>

		</div>


		</div> <!-- end #page div -->

		<div class="banner728-container bottom clearfix">
	<div class="banner728">
		<!-- /250237259/FI_bottom_728x90 -->
<div id='div-gpt-ad-1429758259836-5' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1429758259836-5'); });
</script>
</div>	</div>
	</div>

				<div id="footer-widgets" class="maincontent">
			<div class="limit clearfix">
				<div class="footer-widget1">
					<div id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><b>Contact Frost:</b></p>
<p>• (260) 745-0552</p>
<p>• 3121 S. Calhoun St.<br />
Fort Wayne, IN 46807</p>
</div>
		</div></div>				</div>
				<div class="footer-widget2">
					<div id="search-3" class="widget widget_search"><div class="widget-wrap"><form id="searchform" method="get" action="http://www.frostillustrated.com/" ><input type="text" value="Enter Search Terms" onfocus="if (this.value == 'Enter Search Terms') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Enter Search Terms';}" size="18" maxlength="50" name="s" id="searchfield" /><input type="submit" value="search" id="submitbutton" /></form>
</div></div>				</div>
				<div class="footer-widget3">
					<div id="archives-2" class="widget widget_archive"><div class="widget-wrap"><h3 class="widgettitle"><span>Archives</span></h3>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.frostillustrated.com/2017/04/'> April 2017 </option>
	<option value='http://www.frostillustrated.com/2017/03/'> March 2017 </option>
	<option value='http://www.frostillustrated.com/2017/02/'> February 2017 </option>
	<option value='http://www.frostillustrated.com/2017/01/'> January 2017 </option>
	<option value='http://www.frostillustrated.com/2016/12/'> December 2016 </option>
	<option value='http://www.frostillustrated.com/2016/11/'> November 2016 </option>
	<option value='http://www.frostillustrated.com/2016/10/'> October 2016 </option>
	<option value='http://www.frostillustrated.com/2016/09/'> September 2016 </option>
	<option value='http://www.frostillustrated.com/2016/08/'> August 2016 </option>
	<option value='http://www.frostillustrated.com/2016/07/'> July 2016 </option>
	<option value='http://www.frostillustrated.com/2016/06/'> June 2016 </option>
	<option value='http://www.frostillustrated.com/2016/05/'> May 2016 </option>
	<option value='http://www.frostillustrated.com/2016/04/'> April 2016 </option>
	<option value='http://www.frostillustrated.com/2016/03/'> March 2016 </option>
	<option value='http://www.frostillustrated.com/2016/02/'> February 2016 </option>
	<option value='http://www.frostillustrated.com/2016/01/'> January 2016 </option>
	<option value='http://www.frostillustrated.com/2015/12/'> December 2015 </option>
	<option value='http://www.frostillustrated.com/2015/11/'> November 2015 </option>
	<option value='http://www.frostillustrated.com/2015/10/'> October 2015 </option>
	<option value='http://www.frostillustrated.com/2015/09/'> September 2015 </option>
	<option value='http://www.frostillustrated.com/2015/08/'> August 2015 </option>
	<option value='http://www.frostillustrated.com/2015/07/'> July 2015 </option>
	<option value='http://www.frostillustrated.com/2015/06/'> June 2015 </option>
	<option value='http://www.frostillustrated.com/2015/05/'> May 2015 </option>
	<option value='http://www.frostillustrated.com/2015/04/'> April 2015 </option>
	<option value='http://www.frostillustrated.com/2015/03/'> March 2015 </option>
	<option value='http://www.frostillustrated.com/2015/02/'> February 2015 </option>
	<option value='http://www.frostillustrated.com/2015/01/'> January 2015 </option>
	<option value='http://www.frostillustrated.com/2014/12/'> December 2014 </option>
	<option value='http://www.frostillustrated.com/2014/11/'> November 2014 </option>
	<option value='http://www.frostillustrated.com/2014/10/'> October 2014 </option>
	<option value='http://www.frostillustrated.com/2014/09/'> September 2014 </option>
	<option value='http://www.frostillustrated.com/2014/08/'> August 2014 </option>
	<option value='http://www.frostillustrated.com/2014/07/'> July 2014 </option>
	<option value='http://www.frostillustrated.com/2014/06/'> June 2014 </option>
	<option value='http://www.frostillustrated.com/2014/05/'> May 2014 </option>
	<option value='http://www.frostillustrated.com/2014/04/'> April 2014 </option>
	<option value='http://www.frostillustrated.com/2014/03/'> March 2014 </option>
	<option value='http://www.frostillustrated.com/2014/02/'> February 2014 </option>
	<option value='http://www.frostillustrated.com/2014/01/'> January 2014 </option>
	<option value='http://www.frostillustrated.com/2013/12/'> December 2013 </option>
	<option value='http://www.frostillustrated.com/2013/11/'> November 2013 </option>
	<option value='http://www.frostillustrated.com/2013/10/'> October 2013 </option>
	<option value='http://www.frostillustrated.com/2013/09/'> September 2013 </option>
	<option value='http://www.frostillustrated.com/2013/08/'> August 2013 </option>
	<option value='http://www.frostillustrated.com/2013/07/'> July 2013 </option>
	<option value='http://www.frostillustrated.com/2013/06/'> June 2013 </option>
	<option value='http://www.frostillustrated.com/2013/05/'> May 2013 </option>
	<option value='http://www.frostillustrated.com/2013/04/'> April 2013 </option>
	<option value='http://www.frostillustrated.com/2013/03/'> March 2013 </option>
	<option value='http://www.frostillustrated.com/2012/11/'> November 2012 </option>

		</select>
</div></div>				</div>
				<div class="footer-widget4">
									</div>
			</div>
		</div>
		
	</div>  <!-- end #wrap div -->

</div> <!-- end #outer-wrap div -->

<div id="footer">

	<div class="limit clearfix">

		<div class="sub-icons clearfix">

	<a title="Subscribe via RSS Feed" href="http://www.frostillustrated.com/feed/"><img class="rss-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/feed.png" alt="Subscribe via RSS Feed" align="top" /></a>

	<a rel="external" title="Follow us on Twitter!" href="http://www.twitter.com/frostillustrate"><img class="twitter-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/twitter.png" alt="Follow us on Twitter!" align="top" /></a>

	<a title="Connect on Facebook" rel="external" href="http://www.facebook.com/frostillustrated"><img class="facebook-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/facebook.png" alt="Connect on Facebook" align="top" /></a>

	<a title="Connect on Google Plus" rel="external" href="https://plus.google.com/+frostillustrated?rel=author"><img class="gplus-sub" src="http://www.frostillustrated.com/wp-content/themes/wp-prosper204-child/images/google-plus.png" alt="Connect on Google Plus" align="top" /></a>






</div>
		&copy;  2017 Frost Illustrated. All rights reserved.

	</div>

</div>


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.frostillustrated.com\/2017\/film-review-t2-trainspotting\/":81082,"http:\/\/www.frostillustrated.com\/2015\/video-interview-with-rose-broadnax-on-justice-or-else-march\/":75967,"http:\/\/www.frostillustrated.com\/2015\/interview-with-nicole-king\/":75868};
		window.WPCOM_jetpack = true;
				window.WPCOM_site_ID = 47721293;
			</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/film-review-t2-trainspotting/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://www.frostillustrated.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
			jQuery(document).on('ready', function(){
				jQuery('body').on('click', 'a.share-pinterest', function(e){
					e.preventDefault();

					// Load Pinterest Bookmarklet code
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);

					// Trigger Stats
					var s = document.createElement("script");
					s.type = "text/javascript";
					s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
					var x = document.getElementsByTagName("script")[0];
					x.parentNode.insertBefore(s, x);
				});
			});
			</script>
		<script type='text/javascript' src='http://www.frostillustrated.com/wp-includes/js/comment-reply.min.js?ver=4.2.14'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201716'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.frostillustrated.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=3.5.3'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201716.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.5.3',blog:'47721293',post:'81082',tz:'-4',srv:'www.frostillustrated.com'} ]);
	_stq.push([ 'clickTrackerInit', '47721293', '81082' ]);
</script>

</body>

</html>